Install Hugo on Raspberry Pi 4

Quick memo for installing hugo on Raspberry Pi 4. It worked on Nov 26, 2019.

Step

About an error

After installing snap, executing snap command (also hugo command after its installation) gives the following error.

ERROR: ld.so: object ‘/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.

I ended up editing /etc/ld.so.preload and commenting out /usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so, meaning

$ nano /etc/ld.so.preload
then, #/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so

Not exactly sure why this happens, but after some googling, there exist some people who have the same trouble and no solution found. It seems harmless error so I just commented out. If you are curious, the following links might help: